Author Topic: Probe Issue - Thermopro TP-20  (Read 444 times)

sumdume

  • Newbie
  • *
  • Posts: 1
Probe Issue - Thermopro TP-20
« on: September 04, 2022, 09:35:31 PM »
I had an issue today when smoking a Turkey Breast with cherry ???.  It turned out great.
I have a Thermopro TP-20 setup and the probes do show the same temperature.
On probe seems to run 10 to 20 degrees higher than the other  In addition, the probes do not match my instant read thermometer.
After cooking the bird, I put the tips of the probes in a coffee cup with ice water.  At one point probe 1 showed 70 degrees and probe 2 showed 100 degrees.  The instant read showed about 40 degrees.  I thought maybe because I only had a portion of the probe in the ice water it affected the temperature reading.  Tomorrow, I will put them in boiling water and see what happens.
After that, I put them on the counter for a few hours.  Probe 1 showed 133, probe 2 showed 147 and the instant read showed 78.
Has anyone else encountered this issue?

old sarge

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3769
Re: Probe Issue - Thermopro TP-20
« Reply #1 on: September 05, 2022, 11:41:20 AM »
Thermoworks will be you best option to solving your problem.
David from Arizona
US Army 70 - 95
SI 3D & Big Red Controller
CS 066
Lodge Sportsman Grill
Weber Kettle
Ducane Meridian 42 inch Grill
LEM MaxVac 1088A
LEM Big Bite #8 Grinder
Chef's Choice 665 and Rival Slicers
Old Hickory Knives
InstantPot Duo80 Plus

LarryD

  • Hero Member
  • *****
  • Posts: 952
  • 3DW - Eugene, OR
Re: Probe Issue - Thermopro TP-20
« Reply #2 on: September 06, 2022, 12:33:38 AM »
It sounds like a minimum of 2/3 of your probes are faulty/defective.
------------------------------
See where the Smokin-It Forum Members are located: https://goo.gl/iFgTi1  -- Message me to be added...